Back to overview
Degraded

Degradation of services

Jul 23 at 09:23am PDT
Affected services
marketplace
api

Resolved
Jul 23 at 09:43am PDT

We have restored performance in our downstream service areas and will continue monitoring these functions in the Platform.

If you encounter any issues, please contact Support@LevelTenEnergy.com.

Created
Jul 23 at 09:23am PDT

We are currently experiencing degraded performance in downstream service areas due to a Google provider issue. Our team is working with Google to resolve this. Please contact Support@LevelTenEnergy.com with any questions.